summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorPaweł Dybiec <pawel@dybiec.info>2024-01-27 01:48:57 +0000
committerPaweł Dybiec <pawel@dybiec.info>2024-01-27 01:48:57 +0000
commit4920d8e9b6f6655baaffb15c39422264119f6f26 (patch)
tree84cf1fa7c184edb5daa303523d8864fa88dbdb03 /Cargo.toml
parentMerge branch 'nixos_test' into 'main' (diff)
Update structs in model
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2cb25b3..d683e3c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,11 +8,15 @@ edition = "2021"
 [dependencies]
 anyhow = "1.0.*"
 async-trait = ">=0.1.60"
-async-tungstenite = { version = "*", features = ["tokio-runtime","tokio-native-tls"] }
+async-tungstenite = { version = "*", features = [
+    "tokio-runtime",
+    "tokio-native-tls",
+] }
 futures-util = { version = "0.3.*", features = ["tokio-io"] }
 reqwest = { version = "0.11.*", features = ["serde_json", "json"] }
 serde = { version = "1.0.*", features = ["serde_derive"] }
 serde_json = "1.0.*"
+serde_with = { version = "3.5.1", features = ["json"] }
 sqlite = "0.30.*"
 tokio = { version = "1.28.*", features = ["full"] }
 tokio-macros = "1.8.*"