summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorPaweł Dybiec <pawel@dybiec.info>2022-12-24 00:22:21 +0000
committerPaweł Dybiec <pawel@dybiec.info>2022-12-24 00:22:21 +0000
commit86f5bb9301a169d7b8d22c3165b05db4727415e5 (patch)
treee61027adb19e2fc443b434e47fe1f7413cd029c7 /Cargo.toml
Initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..855f0bb
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "vavbot"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0.68"
+async-tungstenite = { version = "*", features = ["tokio-runtime","tokio-native-tls"] }
+futures-util = { version = "0.3.25", features = ["tokio-io"] }
+reqwest = { version = "0.11.13", features = ["serde_json", "json"] }
+serde = { version = "1.0.151", features = ["serde_derive"] }
+serde_json = "1.0.91"
+tokio = { version = "1.23.0", features = ["full"] }
+tokio-macros = "1.8.2"
+tracing = "0.1.37"
+tracing-subscriber = { version = "0.3.16", features = ["env-filter"] }