summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorPaweł Dybiec <pawel@dybiec.info>2023-08-27 12:50:31 +0100
committerPaweł Dybiec <pawel@dybiec.info>2023-08-27 12:50:31 +0100
commit29e78ee652a23da403385959dd618719e21a5c27 (patch)
treec0d35a9c7235bd54a114f38c486f749187f250a8 /flake.nix
parentUse nix for docker builds (diff)
Terminate on connection error
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index 2326526..6d49a6f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -36,14 +36,15 @@
           };
           cargoArtifacts = craneLib.buildDepsOnly commonArgs;
           bin = craneLib.buildPackage (commonArgs // { inherit cargoArtifacts; });
-          dockerImage = pkgs.dockerTools.streamLayeredImage {
-            name = "vavbot";
-            tag = "latest";
-            contents = [ bin pkgs.cacert ];
-            config = {
-              Cmd = [ "${bin}/bin/vavbot" ];
+          dockerImage = pkgs.dockerTools.streamLayeredImage
+            {
+              name = "vavbot";
+              tag = "latest";
+              contents = [ bin pkgs.cacert ];
+              config = {
+                Cmd = [ "${bin}/bin/vavbot" ];
+              };
             };
-          };
         in
         with pkgs;
         {